Application slowness
Incident Report for Burner
Resolved
App fully operational
Posted 2 months ago. Oct 03, 2017 - 16:12 PDT
Investigating
Some users might be experiencing slowness loading or sending text messages. We are investigating the issue.
Posted 2 months ago. Oct 03, 2017 - 15:18 PDT