App slowdown
Incident Report for Burner
Resolved
The incident has been resolved.
Posted 8 months ago. Sep 28, 2017 - 10:14 PDT
Investigating
We are currently investigating some slowness in the app
Posted 8 months ago. Sep 28, 2017 - 10:07 PDT