Purchasing Issues
Incident Report for Burner
Resolved
Purchasing issues resolved for iPhone users
Posted 9 months ago. Jan 10, 2017 - 21:23 PST
Monitoring
Monitoring isolated purchasing issues on iPhones
Posted 9 months ago. Jan 09, 2017 - 20:37 PST
Investigating
We're investigating purchasing issues for some iPhone users. If you're having an issue purchasing, contact us at support@burnerapp.com
Posted 9 months ago. Jan 09, 2017 - 15:14 PST