Carrier Issues
Incident Report for Burner
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 08:24 PDT
Investigating
Our service is being impacted by wide-spread carrier issues impacting some calls and messages across the United States. We’re tracking the status and will provide updates as we get more information.
Posted Jun 15, 2020 - 15:47 PDT
This incident affected: Calls and SMS.