Contact Form not working
Incident Report for Burner
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 12, 2019 - 16:45 PDT
Investigating
The "Email Us" Support form on our website (which can be found here: https://support.burnerapp.com/customer/portal/emails) is not working. If you need to contact our Support team, please email them directly at support@burnerapp.com!
Posted about 2 months ago. Jun 26, 2019 - 10:49 PDT