Performance issue causing some slowdowns
Incident Report for Burner
Resolved
Performance issues resolved. App should be returning to normal.
Posted 7 months ago. May 08, 2017 - 13:29 PDT
Identified
We're working on getting the app back up to speed
Posted 7 months ago. May 08, 2017 - 12:28 PDT