Google Play Purchasing Issues

Incident Report for Burner

Resolved

This incident has been resolved.
Posted Dec 10, 2019 - 09:43 PST

Investigating

Our service with the Google Play store is currently down. We're working with them to get it back up as quickly as possible. If you're having an issue purchasing, please contact us at support@burnerapp.com.
Posted Dec 10, 2019 - 09:27 PST