Intermittent iTunes Payment Failures
Incident Report for Burner
Resolved
This incident has been resolved.
Posted Jan 24, 2020 - 16:16 PST
Investigating
We’re experiencing a partial outage from the iTunes Store that may be causing payment failures. If you’re unsuccessfully trying to make a purchase, we apologize for the inconvenience. Please try again later and email support@burnerapp.com with any questions.
Posted Jan 24, 2020 - 12:09 PST