Canadian Sign Up Issues
Incident Report for Burner
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 07, 2019 - 09:54 PDT
Monitoring
A fix has been implemented and we're monitoring the results.
Posted 2 months ago. Jun 07, 2019 - 08:40 PDT
Identified
We've identified an issue that is preventing Canadian customers from signing up and have implemented a fix. If you're a Canadian customer who is having issues signing up for Burner, please reach out to our Support team at support@burnerapp.com.
Posted 2 months ago. Jun 07, 2019 - 08:32 PDT
This incident affected: Burner Server.