Application Slowness
Incident Report for Burner
Resolved
This incident has been resolved.
Posted May 21, 2018 - 15:26 PDT
Investigating
We are investigating an issue with application slowness.
Posted May 21, 2018 - 14:35 PDT
This incident affected: Calls, SMS, and Burner Server.