Incoming messages delays
Incident Report for Burner
Resolved
This issue has been resolved and all delayed messages have been delivered.
Posted 11 months ago. Nov 05, 2017 - 22:54 PST
Investigating
We are currently having problems delivering messages in our queue.
Posted 11 months ago. Nov 05, 2017 - 19:50 PST