Some Inbound Call Issues
Incident Report for Burner
Resolved
Inbound calling fully functioning
Posted 11 months ago. Jul 27, 2017 - 18:29 PDT
Identified
Affecting a small number of people - some users may experience inbound calls getting dropped due to an upstream carrier issue. We're currently investigating and working to resolve as soon as possible.
Posted 11 months ago. Jul 27, 2017 - 17:12 PDT