Inbound text issues
Incident Report for Burner
Resolved
The issue with inbound texts has been resolved.
Posted 13 days ago. Feb 09, 2018 - 19:39 PST
Investigating
We are currently experiencing an issue with incoming text messages.
Posted 14 days ago. Feb 09, 2018 - 16:18 PST