Application Slowness
Incident Report for Burner
Resolved
This incident has been resolved.
Posted May 23, 2018 - 17:31 PDT
Investigating
Some users might be experiencing slowness loading or sending text messages and calls. We are investigating the issue.
Posted May 23, 2018 - 16:06 PDT
This incident affected: Calls, SMS, and Burner Server.