Slowness and problems creating numbers
Incident Report for Burner
Resolved
The issue has been resolved
Posted 11 months ago. Aug 17, 2018 - 23:03 PDT
Investigating
We are investigating an issue with our upstream provider related to problems purchasing new numbers. This issue is also causing the application to be slower.
Posted 11 months ago. Aug 17, 2018 - 22:47 PDT
This incident affected: Burner Server.