Investigating Service Provider Issue
Incident Report for Burner
Resolved
Resolved SMS and calling issue with service provider. App is functioning as normal.
Posted 5 months ago. Aug 03, 2017 - 10:53 PDT
Investigating
SMS and calls may not work.
Posted 5 months ago. Aug 03, 2017 - 09:58 PDT